`
20386053
  • 浏览: 434767 次
文章分类
社区版块
存档分类
最新评论

POJ 2046 Power Strings

阅读更多



Time Limit:3000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

[] [Go Back] [Status]

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

[] [Go Back] [Status]



可以枚举长度用后缀数组,也可以用KMP的next数组求最小循环节。。。。


#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

char p[1100000];
int f[1100000];

void getfail(char* p,int* f)
{
    int m=strlen(p);
    f[0]=f[1]=0;
    for(int i=1;i<m;i++)
    {
        int j=f[i];
        while(j&&p[i]!=p[j]) j=f[j];
        f[i+1]=(p[i]==p[j])?j+1:0;
    }
}

int main()
{
    while(scanf("%s",p)!=EOF)
    {
        if(p[0]=='.'&&p[1]==0) break;
        memset(f,0,sizeof(f));
        getfail(p,f);
        int m=strlen(p);
        if(f[m]&&(m%(m-f[m]))==0)
        {
            printf("%d\n",m/(m-f[m]));
        }
        else puts("1");
    }
    return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics